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1
Installing the Series 40 Developer Platform 2.0 
SDK

This document the describes what you need to know and do to install the Series 40 Developer 
Platform 2.0 SDK (S40 DP 2.0 SDK) and to configure it for use within an integrated development 
environment (IDE).

What is the Series 40 Developer Platform 2.0 SDK?
The Series 40 Developer Platform 2.0 SDK is a development tool that lets you preview how 
wireless content will look and work when it is ultimately deployed to a Nokia mobile handset that 
complies with the Series 40 Developer Platform 2.0. 
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The Series 40 Developer Platform 2.0 supports:

What do you need to install the SDK?
Before installing the SDK, check that you have the minimum hardware and software requirements 
listed in this section. With these minimum requirements, you can run the SDK as a standalone 
application. If you plan to use the SDK within an integrated development environment (IDE), 
make sure you also have the requirements mandated by the IDE.

Hardware requirements
The hardware requirements to run the SDK as a standalone tool are:

Area Specifics

J2ME MIDP 2.0 JSR 118

CLDC 1.1

JWTI (JSR-185 release 1)

WMA (JSR-120 version 1.1)

MMA (JSR-135, MIDI/audio only required)

BTA (JSR-82)

Browsing XHTML MP

UAProf (static)

Messaging MMS with 3GPP SMIL support

OMA Digital Rights Management 1.0 Not for MIDlets

Device Management OMA Client Provisioning 1.1

WAPF/OMA Bootstrapping

Wallet 2.0

Minimum Recommended

667 MHz Pentium processor 1800Mhz Pentium processor

70 MB of free disk space 70 MB of free disk space

256 MB RAM 512Mb RAM

16 bit color More than 16 bit color

1024x768 pixel display More than 1024x768 pixel display

Keyboard and mouse Keyboard and mouse
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If you plan to work with sound (from MIDlets, for instance) you’ll also want to have a sound card 
that has one channel for every SDK instance you run. If you do not have enough channels, SDK 
instances that you start after you run out of channels will not have sound.

Software requirements
Use one of these operating systems as a minimum software requirement to run the S40 DP 2.0 SDK 
as a standalone:

• Windows 2000 SP3

• Windows XP Service Pack 1a

• Windows 2000 Chinese Service Pack 3

• Windows XP Professional Chinese Service Pack 1a

You will also need to install a public Java Runtime Environment (JRE) 1.4.1_02 or higher before 
you install the SDK). For more information about JRE versions and public location, see If the 
installer cannot find a JRE ... on page 9.

Acquiring the S40 DP 2.0 SDK and a product serial number
To install the SDK, you’ll need: 

• The .zip file containing the SDK

• A product serial number that you’ll need when you run the installation wizard

At no cost to you, you can get both directly from www.forum.nokia.com. If you are not a 
registered member of Forum Nokia, you will need to register (also at no cost) before you can 
download the SDK. Registration involves providing a user name and password and an email 
address.

Acquiring a serial number before you install
To get a serial number when you download the SDK, click Request Serial Number on the same 
web page as the download link. The product serial number is immediately sent to the email 
address you provided when you registered with Forum Nokia. You will need this number when you 
install the product.

Acquiring a serial number while you install
During installation, you can get a serial number by submitting your Forum Nokia username and 
password through the installation wizard. The serial number is immediately sent to the email 
address you provided when you registered with Forum Nokia.
If you use this method to get the serial number, make sure you have these two items before you run 
the installation wizard:
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• An active Internet connection while you install the SDK. The installation wizard 
requests a product serial number from the Forum Nokia web site, which is sent to you 
through email during the installation. (If you ever need to reinstall the SDK, you don’t 
need an Internet connection. You can enter the product serial number you already 
have.) 

• Proxy Server Information. If you plan to get a serial number while you are running the 
installation wizard and your computer is on a network that uses a proxy server, 
obtain from your local network administrator the IP address and port number of the 
proxy server your system uses for Internet access.

To install the SDK for use with supporting applications
In addition to using the SDK as a standalone tool, you can use the SDK within an integrated 
development environment (IDE). S40 DP 2.0 SDK has been tested with these IDEs but may work 
with other IDEs as well:

• Nokia Mobile Internet Toolkit 4.1.

• Adobe GoLive CS (directly and through NDS for MMS 1.1)

• NDS for MMS 1.1

• Nokia Developer's Suite for the Java 2 Platform Micro Edition 2.0 (NDS for J2ME 
tool, standalone installation)

• Nokia Developer's Suite for the Java 2 Platform Micro Edition 2.1 (NDS for J2ME) 
tool, standalone installation

• JBuilder 9 (Personal, Professional, or Enterprise editions) with or without NDS for 
J2ME.

• JBuilder X (Personal, Professional, or Enterprise editions) with or without NDS for 
J2ME.\

• Sun J2ME Wireless Toolkit 2.1 application environment 

• Sun One Studio 5.0 Mobile Edition application environment (with or without NDS 
from J2ME integration)

Installing the S40 DP 2.0 SDK for use with J2MEWTK
If you plan to use the SDK with J2ME Wireless Toolkit, install the SDK after you install 
J2MEWTK. Optionally, to facilitate the integration of the SDK with J2MEWTK, you can first 
install NDS for J2ME and then the SDK.

Installing the S40 DP 2.0 SDK for use with JBuilder
You can install the SDK before or after you install JBuilder.
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Using NDS for J2ME to facilitate SDK integration
Optionally, you can install NDS for J2ME before installing the S40 DP 2.0 SDK to facilitate 
integration with: 

• JBuilder

• Sun One Studio 

Running the installation wizard
To install S40 DP 2.0 SDK:

1 Make sure: 

• Your system meets the hardware and software requirements. See What do you need 
to install the SDK? on page 4.

• You have installed supported applications in the correct order so the applications 
can find the SDK. See To install the SDK for use with supporting applications on 
page 6.

• You have acquired a product serial number or have the necessary information to 
get it during installation. See Acquiring the S40 DP 2.0 SDK and a product serial 
number on page 5.

2 Double-click the .zip file you downloaded to unzip it. 

3 Double-click the file install.exe. The installation wizard begins to run.
Caution:  Do not cancel the wizard after you click Install. If you decide you do not want to 

install the product, let the installation complete and then uninstall the product. This 
approach prevents the product from being partially installed in a way that an 
uninstaller cannot automatically remove

Launching S40 DP 2.0 SDK
You can launch the SDK as a standalone application or within an IDE.

Launching the SDK as a standalone application
To launch the SDK standalone from the Windows GUI, select:
Start menu>Programs>Nokia Developer Tools>DP 2.0 SDKs>Series 40>S40 DP 2.0 
SDK 1.0 

Launching the SDK within an IDE
You’ll need to configure some IDEs to recognize the SDK as a supported device before you can 
launch the SDK from within the IDE interface. For this information, see:
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• The documentation for your IDE

• Configuring for Browser and Message Content Development on page 11

• Configuring for MIDP Development on page 15

Adding additional languages for SDK menus
The SDK is installed with the capability to display its menus in these languages:

• English

• German

• Turkish

• Spanish

• French

• Italian

• Dutch

• Portuguese

You can also display the SDK menus in these other languages by adding World Languages to the 
SDK. The World Languages are freely available from www.forum.nokia.com on the same page 
from which you download the S40 DP 2.0 SDK. Install the World Languages after you install the 
SDK by unpacking the World Languages ZIP file and double-clicking install.exe. You do not 
need a serial number to install the World Languages. 

Uninstalling the S40 DP 2.0 SDK 
To uninstall the SDK, select:
Start menu>Settings>Control Panel>Add/Remove Programs>Series 40 Developer Platform 20 
SDK 
Uninstalling the SDK automatically uninstalls the World Languages, if you added them. You 
cannot uninstall the World Languages separately.

Troubleshooting
Under some conditions, the installation process might stop. This section covers some solutions 
should this happen.

If the installer freezes ...
On some personal computers, the installer might freeze and prevent the installation from being 
completed. To work around this problem, adjust the hardware acceleration setting: Right click on 
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the desktop and select Properties. Then select Settings>Advanced>Troubleshooting. Set the 
acceleration to Disable all but basic accelerations.

If the installer cannot find a JRE ...
If the installer does not find the Java Runtime Environment (JRE) it requires, it stops the 
installation and posts a message. At this time, check the version number and location of the JRE 
you are using. Make sure that:

• The JRE version you have is 1.4.1_02 or greater. 

• The JRE is public - that is, the location of the JRE is in a directory outside the private 
Java 2 SDK. The Nokia SDK will not run without the public JRE.

By default, the Java 2 SDK installs both a private and a public Java 2 Runtime Environment. Make 
sure you accept this default because the Nokia SDK requires the public JRE.
The Java 2 SDK requires the private JRE to run the tools included with the Java 2 SDK. The 
private copy of the JRE has no registry settings and is contained entirely in a JRE directory whose 
location is known only to the Java 2 SDK.
The public JRE:

• Can be used by other Java applications, such as a Nokia SDK

• Is contained outside the Java 2 SDK (typically C:\Program 
Files\Java\j2re1.4.2)

• Is registered in the Windows registry 
(HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft)

• Can be removed using Add/Remove Programs

• Might (or not) be registered with browsers

• Has java.exe and javaw.exe copied to the Windows system directory, making 
the JRE the default system Java platform

Most of the time, the JRE is routinely installed publicly and privately. Occasionally, an application 
or a user will install only the private JRE. If the public JRE was suppressed during an installation, 
you can install a public JRE by doing the following on Windows NT (Service Pack 6a), or 
Windows 2000 (Service Pack 3), or Windows XP (Service Pack 1a):

1 Select Start>Settings>Control Panel and double-click Add/Remove Programs. 

2 Select Java 2 SDK, SE v1.4.2 and click Change. 

3 In the wizard that appears, select Modify. 

4 In the Custom Setup wizard page, set Public Java Runtime Environment to This 
feature will be installed on local hard drive. 

5 Follow the rest of the steps in the wizard. 
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What’s next?
If you plan to work within an integrated development environment (IDE), you’ll need to configure 
some of the supporting applications to work with the SDK. To prepare an IDE in which to create:

• Browser and message content - web content designed to be displayed on a mobile 
phone such as DRM, MMS, Push SI/SL messages, WML, and XHTML content - see 
Configuring for Browser and Message Content Development on page 11.

• MIDP MIDLets - (JAD and JAR files) games or applications that can be downloaded 
from the Internet and used on a mobile phone. See Configuring for MIDP 
Development on page 15.

Or you can see the Series 40 Developer Platform 2.0 SDK User’s Guide for information about using 
the SDK. This manual is located in the installation directory of the SDK. It’s in PDF format, so 
you’ll need Adobe Acrobat Reader to open it. Adobe Acrobat reader is freely available from 
www.adobe.com.
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2
Configuring for Browser and Message Content 
Development

You can work more efficiently by creating an integrated development environment (IDE) where 
you can develop content in an application and directly display it on the SDK. Some applications 
automatically detect the SDK as a device. You’ll need to configure other applications to recognize 
the SDK before you can use the SDK from within the application’s interface. 
For detailed information about step-by-step installation instructions, see the documentation of 
the supporting application. This chapter provides only a general overview of what you need to do 
about configuring these content authoring applications for use with the S40 DP 2.0 SDK:

• Adobe GoLive with Nokia Developer’s Suite for MMS (NDS for MMS) for message 
development

• Adobe GoLive with the WML module for WML and XHTML browsing.
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Configuring the SDK for use with NMIT 
NMIT 4.1 automatically find the SDK and each configures itself to use it.

Configuring NDS for MMS to use the SDK
NDS for MMS 1.1 automatically finds the SDK and configures itself to use it.

Configuring Adobe GoLive to display MMS messages on the SDK
If you are planning to send MMS messages to the SDK while using Adobe GoLive, you’ll need to 
install Nokia Developer’s Suite for MMS (NDS for MMS) after you install Adobe GoLive. NDS 
for MMS is automatically configured to run with the SDK within Adobe GoLive. You do not need 
to configure it manually. NDS for MMS adds a Nokia Tools menu to the Adobe GoLive menu bar. 
Under this menu, you’ll see the option, Create/Send MMS Messages, which starts NDS for MMS.

Configuring Adobe GoLive to display WML and XHTML content 
on the SDK

By default, the WML module for content authoring is not accessible unless you add the module in 
Adobe GoLive preferences before you configure Adobe GoLive to recognize the SDK as a browser. 
To configure Adobe GoLive so you can create a new WML file using a standard WML template:

1 Select Edit>Preferences.

2 On the right panel, select Modules.

3 On the left panel, navigate to the bottom of the list to the Extend Scripts folder and 
check WML.

4 Click OK. 

Now you can create a new WML file by selecting File>New Special>WML Deck.

To add S40 DP 2.0 SDK as a recognized browser to Adobe GoLive:

1 Select Edit>Preferences.

2 On the right panel, select Browser.

3 Click Add. The Choose Browser dialog box appears. 

4 In the Choose Browser dialog box, navigate to the location of the SDK executable file 
(C:\Nokia\Devices\Nokia_S40_DP20_SDK_1_0\bin\S40_DP20.exe) and click OK. 

Now you can display a WML or XHTML file within GoLive’s content editor on the 
SDK by selecting File>Preview In>S40_DP20.exe.
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What’s next?
You can begin to use the S40 DP 2.0 SDK. See the Series 40 Developer Platform 2.0 SDK User’s 
Guide for information about using the SDK. For late-breaking information, see the release notes. 
Both documents are located in the installation directory of the SDK. You can also download the 
documents from www.forum.nokia.com.The manual is in PDF format, so you’ll need Adobe 
Acrobat Reader to open it. Adobe Acrobat reader is freely available from www.adobe.com.
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3
Configuring for MIDP Development

You can work more efficiently by creating an integrated development environment (IDE) where 
you can develop content in an application and directly display it on the SDK. Some applications 
automatically detect the SDK as a device. You’ll need to configure other applications to recognize 
the SDK before you can start the SDK from within the application’s interface. 
For detailed information about step-by-step installation instructions, see the documentation of 
the supporting application. This chapter provides only a general overview of what you need to do 
to configure these MIDP development applications to use the S40 DP 2.0 SDK:

• Borland JBuilder 9 and X

• Nokia Developer’s Suite for J2ME through Borland JBuilder with MobileSet

• Sun One Studio, Mobile Edition
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Configuring JBuilder to use the S40 DP 2.0 SDK
You can use the S40 DP 2.0 SDK as a Java Developer’s Kit (JDK) and as the default device in a 
JBuilder project. You might notice differences in the look of the JBuilder interface, depending on 
the version of JBuilder you are using, but the procedure works identically. 
If you are using JBuilder 9 or earlier, first read If you use JBuilder 9 and earlier to run MIDlets on 
the S40 DP 2.0 SDK on page 19.

Configuring JBuilder to recognize the SDK as a JDK
To configure JBuilder to recognize the SDK as an installed JDK:

1 In the JBuilder main window, choose Tools>Configure JDKs. The Configure JDKs 
window appears.

2 Click New in the Configure JDKs window to start the New JDK Wizard.

3 In the New JDK Wizard, do this:

• In Existing JDK home path, enter the SDK’s installation directory.

• In Name for this JDK, enter a name by which you want JBuilder to refer to the 
SDK - for example, S40 DP 2.0 SDK. (The default entry is S40 DP 2.0 SDK 1.0. If 
field is not editable, check that you have MobileSet installed or that you are 
working with a version of JBuilder that supports J2ME.)

• Click OK to close the New JDK Wizard.

4 The Configure JDK window now lists the SDK on the left panel:

5 Click OK to close the Configure JDK window.
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Configuring a JBuilder project to use the S40 DP 2.0 SDK
To configure a JBuilder project to use the SDK:

1 From the left panel of the JBuilder main window, choose the project you created and 
select Projects>Project Properties to display its properties. The Project Properties 
window appears:

.

2 In the Project Properties window, click the Paths tab and in the JDK field, select the 
Nokia SDK as the SDK to be used for this project. 

3 Click the Run tab in the Project Properties window and create a runtime 
configuration for the project.
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4 Click New. The Runtime Configuration Properties window appears:

5 In the Runtime Configuration Properties window, under Type, select MIDlet to 
configure the runtime parameters you want to use when a MIDlet runs on the S40 DP 
2.0 SDK. The Runtime Configuration Properties window changes to look like this:

.

You can enter command line options 
here. See Running the SDK From the 
Command Line in the Series 40 
Developer Platform 2.0 SDK User’s 
Guide.
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6 With the Runtime Configuration Properties window set to MIDlets, do one of the 
following:

• Click the button adjacent to Main class to display the Choose Main class to run 
window. In this window, navigate to the location of the files of your main class. 
Click OK.

• Click the button adjacent to JAD file to display the Choose JAD file to run 
window. In this window, navigate to the location of the JAD file for your MIDlet. 
Click OK.

7 Click OK to close the Runtime Configuration Properties window.

8 Click OK to close the Project Properties window.

9 In the JBuilder main window, select Run>Project to load and execute the MIDlet on 
the SDK.

If you use JBuilder 9 and earlier to run MIDlets on the S40 DP 2.0 
SDK

You’ll need to implement this workaround to build and debug MIDlets that run on SDKs 
supporting CLDC 1.1 when you use versions of JBuilder 9 and JBuilder 8 Enterprise, which do not 
support CLDC 1.1. The workaround involves reconfiguring your project to use a build.xml file 
that compensates for lack of CLDC 1.1 support.
The build.xml file is shipped with the SDK and is located in the directory <Nokia S40DP20 
home>\examples\build.

Add build.xml file to the JBuilder project (.jpx) directory

To add the build.xml file to the JBuilder project:

1 Use Window Explorer to manually copy the build.xml file from the <Nokia 
S40DP20 home>\examples\build directory to the MIDlet project root directory. 

2 In JBuilder, right-click on the project name. From the menu that appears, select Add 
File/Package/Class.

3 In the window that appears, select the build.xml file from the MIDlet project root 
directory.

An Apache Ant utility icon appears in the project window when the build.xml file 
becomes part of your project. 

Modify the project

Modify the project so that it uses the build.xml file to build the MIDlet instead of the default 
JBuilder build rules:

1 Choose Project/Project Properties.

2 Click the Run tab.
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3 Click Edit. The Runtime Configuration Properties window appears.

4 Under Build Target, select make (build.xml). 

5 Click OK to close the Runtime Configuration Properties window.

6 Click OK to close the Project Properties window.

To run and debug your MIDlet do one of the following in the JBuilder main window:

• Select Run>Run Project.

• Select Run>Debug Project.

You can also right-click on the build.xml file in the project and select Make from the menu.
This workaround does not work with Project>Make Project or Project>Rebuild Project.

Configuring JBuilder to use the SDK with J2ME Wireless Toolkit
J2ME Wireless Toolkit (J2MEWTK) is automatically installed when you install JBuilder.
To configure the SDK with J2MEWTK so the SDK will appear in J2MEWTK’s list of supplied 
emulators, install the SDK in this directory: 
<JBuilder-install-directory>\J2mewtk\wtklib\devices

If you have already installed the SDK but not into this directory, you can copy the entire SDK 
directory structure into <JBuilder-install-directory>\J2mewtk\wtklib\devices.
To make the SDK the active device emulator within J2ME Wireless Toolkit:

1 In the JBuilder main window, choose Tools>Configure JDKs. 

2 Select J2ME Wireless Toolkit in the left panel and click the Micro tab in the right 
panel. The SDK appears as an option under Target Device:

3 Select the SDK from Target Device to make it active.

4 Click OK.

Configuring the SDK with NDS for J2ME through JBuilder
Make sure you chose the Borland JBuilder Integration option when you installed NDS for J2ME.
To configure the SDK with NDS for J2ME through JBuilder:

1 In the JBuilder main window, choose 
Tools>Nokia Developer’s Suite for J2ME>Configure Emulators.

2 Click Add.

3 In the Open dialog box that appears, navigate to the SDK’s configuration file:

• For NDS for J2ME 2.0, select this file:
<Nokia S40DP20 home>\Nokia_S40_DP20_SDK_1_0.xml. 

• For NDS for J2ME 2.1, select the home directory of the SDK:
S40DP20 home>
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4 Click Open.

5 In the Configure Emulators window, check that the SDK name appears in the 
Emulator list.

6 Click Close.

Configuring the SDK with NDS for J2ME 2.0 or 2.1
To configure the SDK with NDS for J2ME:

1 In the NDS for J2ME main window, click the Configure Emulators icon.

2 Click Add.

3 In the Open dialog box that appears, navigate to the SDK’s configuration file:

• For NDS for J2ME 2.0, select this file:
<Nokia S40DP20 home>\Nokia_S40_DP20_SDK_1_0.xml. 

• For NDS for J2ME 2.1, select the home directory of the SDK:
S40DP20 home>

4 Click Open.

5 In the Configure Emulators window, check that the SDK name appears in the 
Emulator list.

6 Click Close.

Configuring the S40 DP 2.0 SDK with Sun One Studio
To configure the S40 DP 2.0 SDK for use with Sun One Studio:

1 In Sun One Studio, click the Runtime tab at the bottom of the Explorer panel. 

2 Right click on the Device Emulator Registry node and choose Add Emulator. 

3 The Add Emulator window appears. Click Browse and navigate to the SDK’s home 
directory (typically, c:\nokia\devices\Nokia_S40_DP20_SDK_1_0) and click 
Open.

4 In the Detected Emulator Type field, make sure Standard UEI Emulator is selected, 
and click Next. The window is updated with read-only SDK configuration 
information. 

5 Click Next. The window is updated with Emulator Details. 

6 Select the S40 DP 2.0 SDK as an emulator device by checking its box.

7 Click Finish. The Add Emulator window closes. You have added the SDK to the IDE. 

To select the S40 DP 2.0 SDK as the default SDK:

1 Click on Device Emulator Registry to open it. 
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2 Select the S40 DP 2.0 SDK from the list of installed emulators. 

3 Right-click on the S40 DP 2.0 SDK and select Set As Default. 

What’s next?
You can begin to use the S40 DP 2.0 SDK. See the Series 40 Developer Platform 2.0 SDK  User’s 
Guide for information about using the SDK. For late-breaking information, see the release notes. 
Both documents are located in the installation directory of the SDK. You can also download the 
documents from www.forum.nokia.com.The manual is in PDF format, so you’ll need Adobe 
Acrobat Reader to open it. Adobe Acrobat reader is freely available from www.adobe.com.
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