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1
Installing the Series 40 SDK 3rd Edition

This document describes what you need to know and do to install the Series 40 Software 
Developer Kit 3rd Edition, (Series 40 SDK 3rd Edition) and to configure it for use within 
an integrated development environment (IDE).

What is the Series 40 SDK 3rd Edition?
The Series 40 Software Developer Kit 3rd Edition is a development tool that lets you 
preview how wireless content will look and work when it is ultimately deployed to a 
Nokia mobile handset that complies with the Series 40 Developer Platform 3.0.
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The Series 40 SDK 3rd Edition supports:

What do you need to install the SDK?
Before installing the SDK, check that you have the minimum hardware and software 
requirements listed in this section. With these minimum requirements, you can run the 
SDK as a standalone application. If you plan to use the SDK within an integrated 
development environment (IDE), make sure you also have the requirements mandated by 
the IDE.
To install the SDK properly, you must have administrator privileges on your computer. 
Also, be sure to use your normal logon ID (the one you will use to run the SDK). If this 
ID is not set up as an administrator, contact your system administrator. At a minimum, 
you need admistrator privileges assigned temporarily for the installation.

Area Specification

Java ME JSR 75 File connection and PIM APIs

JSR 82 Bluetooth API 

JSR 118 Mobile Information Device Profile 
(MIDP) 2.0

JSR 120 v1.1 Wireless Messaging API

JSR 135 v1.1 Mobile Media API (audio play only; 
no support for video, audio recording, or FM 
radio)

JSR 139 Connected Limited Device 
Configuration 1.1 (CLDC)

JSR 184 3D Graphics API 

JSR 185 Java Technology for Wireless Industry 

Browsing XHTML Mobile Phone Profile (MP)

User Agent Profile (UAProf) static

Messaging MMS with SMIL support

OMA Digital Rights Management 
1.0

Digital Rights Management
OMA Digital Rights Management (DRM) 1.0 
(not for MIDlets)

Device Management OMA Client Provisioning 1.1

WAP/OMA Bootstrapping
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Hardware requirements
The hardware requirements to install and run the SDK as a standalone tool are:

If you plan to work with sound (from MIDlets, for instance) you’ll also want to have a 
sound card that has one channel for every SDK instance you run. If you do not have 
enough channels, SDK instances that you start after you run out of channels will not 
have sound.

Software requirements
Use one of these operating systems as a minimum software requirement to run the 
Series 40 SDK 3rd Edition as a standalone:

• Windows XP Professional Service Pack 2

• Windows XP Personal Service Pack 2

• Windows XP Professional Chinese Service Pack 2

• Windows XP Personal Chinese Service Pack 2

You will also need to install a public Java Runtime Environment (JRE) 1.4.2 or higher 
before you install the SDK). For more information about JRE versions and public 
location, see If the installer cannot find a JRE ... on page 9.

Acquiring the Series 40 SDK 3rd Edition
To install the SDK, you’ll need the .zip file containing the SDK. At no cost to you, you 
can get it directly from www.forum.nokia.com. If you are not a registered member of 
Forum Nokia, you will need to register (also at no cost) before you can download the 
SDK. Registration involves providing a user name, password, and email address.

Minimum Recommended

667 MHz Pentium processor 1.8 GHz Pentium processor

70 MB of free hard disk space 80 MB of free hard disk space

256 MB RAM 512 MB RAM

16-bit color 24-bit color or more

1024x768 pixel display 1024x768 pixel display or more

Keyboard and mouse Keyboard and mouse

http://www.forum.nokia.com
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To install the SDK for use with supporting applications
In addition to using the SDK as a standalone tool, you can use the SDK within an 
integrated development environment (IDE). Series 40 SDK 3rd Edition has been tested 
with these IDEs but may work with other IDEs as well:

• Nokia Mobile Internet Toolkit 4.1. (NMIT 4.1)

• Nokia Developer’s Suite for the Java™ Platform, Micro Edition 3.0.1 (NDS for 
Java ME) tool, standalone installation

• Nokia Developer’s Suite for MMS 1.1 (NDS for MMS 1.1)

• Adobe GoLive CS, directly and through NDS for MMS 1.1

• Adobe GoLive CS2, directly and through NDS for MMS 1.1

• Eclipse 3.1, with NDS for Java ME integration

• JBuilder 2005 Developer edition, with or without NDS for Java ME

• Sun J2ME Wireless Toolkit 2.2 application environment 

• Sun NetBeans 4.1

Installing the Series 40 SDK 3rd Edition for use with J2MEWTK
If you plan to use the SDK with J2ME Wireless Toolkit, install the SDK after you install 
J2MEWTK. Optionally, to facilitate the integration of the SDK with J2MEWTK, you 
can first install NDS for Java ME and then the SDK.

Installing the Series 40 SDK 3rd Edition for use with JBuilder
You can install the SDK before or after you install JBuilder.

Installing the Series 40 SDK 3rd Edition for use with Eclipse
To use Eclipse with the SDK you’ll have to install these applications in this order: Java 
Developer Kit (JDK), Eclipse, NDS for Java ME 3.0.1, and then Series 40 SDK 
3rd Edition. When you install NDS for Java ME, make sure you select the option to 
integrate NDS for Java ME with Eclipse, or the two applications will not work together 
correctly.

Using NDS for Java ME to facilitate SDK integration
Optionally, you may install NDS for Java ME to facilitate the integration of JBuilder or 
Sun NetBeans with the Series 40 SDK 3rd Edition. If you do, install NDS for Java ME 
before installing the Series 40 SDK 3rd Edition.
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Running the installation wizard
To install the Series 40 SDK 3rd Edition:

1 Make sure: 

• Your system meets the hardware and software requirements. See What do you need 
to install the SDK? on page 4.

• You have installed supported applications in the correct order so the applications 
can find the SDK. See To install the SDK for use with supporting applications on 
page 6.

2 Double-click the .zip file you downloaded to unzip it. 

3 Double-click the file S40_SDK_3rd_Edition_installer.exe. The installation 
wizard begins to run.

Caution:  Do not cancel the wizard after you click Install. If you decide you do not want to 
install the product, let the installation complete and then uninstall the product. This 
approach prevents the product from being partially installed in a way that an 
uninstaller cannot automatically remove.

Registering the SDK
You can run the SDK for a fixed period (usually 14 days) before you will need to register 
it with a serial number. If you do not register the SDK, you will not be able to use it after 
the trial time elapses. Registration is free. Just follow the directions in the registration 
wizard that appears when your trial period is over.
You can always check how many days are left of the trial period by selecting 
Help>About.
To register the product at any time, select Help>Register Now, which opens the 
Registration wizard. 

Launching Series 40 SDK 3rd Edition
You can launch the SDK as a standalone application or within an IDE.

Launching the SDK as a standalone application
To launch the SDK standalone from the Windows GUI, select:
Start menu>Programs>Nokia Developer Tools>SDKs>Series 40>Series 40 SDK 3rd 
Edition.
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Launching the SDK within an IDE
You’ll need to configure some IDEs to recognize the SDK as a supported device before 
you can launch the SDK from within the IDE interface. For this information, see:

• The documentation for your IDE

• Configuring for Browser and Message Content Development on page 11

• Configuring the SDK for MIDP Development on page 15

Adding additional languages for SDK menus
The SDK is installed with the capability to display its menus in several languages. These 
languages are listed in Tools>Preferences> General tab. 
You can display the SDK menus in additional languages by adding World Languages to 
the SDK. The World Languages are freely available from www.forum.nokia.com on the 
same page from which you download the SDK. 
Install the World Languages after you install the SDK by unpacking the World 
Languages ZIP file and double-clicking 
S40_SDK_3rd_Edition_WorldLang_installer.exe.

Uninstalling the Series 40 SDK 3rd Edition 
To uninstall the SDK, go to the Control Panel and select Add/Remove Programs. Then 
select Series 40 SDK 3rd Edition.
Uninstalling the SDK automatically uninstalls the World Languages, if you added them. 
You cannot uninstall the World Languages separately.

Troubleshooting
Under some conditions, the installation process might stop. This section covers some 
solutions should this happen.

If the installer freezes ...
On some personal computers, the installer might freeze and prevent the installation 
from being completed. To work around this problem, adjust the hardware acceleration 
setting: 

1 Right-click on the desktop and select Properties. 

2 Select Settings>Advanced>Troubleshooting. 

3 Set the acceleration to Disable all but basic accelerations.

4 Install the SDK.

http://www.forum.nokia.com
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5 Reset the acceration setting to their previous settings.

If the installer cannot find a JRE ...
If the installer does not find the Java Runtime Environment (JRE) it requires, it stops the 
installation and posts a message. At this time, check the version number and location of 
the JRE you are using. Make sure that:

• The JRE version you have is 1.4.2 or higher. 

• The JRE is public - that is, the location of the JRE is in a directory outside the private 
Java 2 SDK. The Nokia SDK will not run without the public JRE.

By default, the Java 2 SDK installs both a private and a public JRE. Make sure you 
accept this default because the Nokia SDK requires the public JRE.
The Java 2 SDK requires the private JRE to run the tools included with the Java 2 SDK. 
The private copy of the JRE has no registry settings and is contained entirely in a JRE 
directory whose location is known only to the Java 2 SDK.
The public JRE:

• Can be used by other Java applications, such as a Nokia SDK

• Is contained outside the Java 2 SDK (typically C:\Program 
Files\Java\j2re1.4.2)

• Is registered in the Windows registry (HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft)

• Can be removed using Add/Remove Programs

• Might (or not) be registered with browsers

• Has java.exe and javaw.exe copied to the Windows system directory, making the 
JRE the default system Java platform

Most of the time, the JRE is routinely installed publicly and privately. Occasionally, an 
application or a user will install only the private JRE. If the public JRE was suppressed 
during an installation, you can install a public JRE by doing the following on 
Windows XP (Service Pack 2):

1 Select Start>Settings>Control Panel and double-click Add/Remove Programs. 

2 Select Java 2 SDK, SE v1.4.2 and click Change. 

3 In the wizard that appears, select Modify. 

4 In the Custom Setup wizard page, set Public Java Runtime Environment to This 
feature will be installed on local hard drive. 

5 Follow the rest of the steps in the wizard. 
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What’s next?
If you plan to work within an integrated development environment (IDE), you’ll need to 
configure some of the supporting applications to work with the SDK. To prepare an IDE 
in which to create:

• Browser and message content - web content designed to be displayed on a mobile 
phone such as DRM, MMS, Push SI 0messages, WML, and XHTML content - see 
Configuring for Browser and Message Content Development on page 11.

• MIDP MIDlets - (JAD and JAR files) games or applications that can be downloaded 
from the Internet and used on a mobile phone. See Configuring the SDK for MIDP 
Development on page 15.

Or you can see the Series 40 Software Developer Kit 3rd Edition User’s Guide for 
information about using the SDK. This manual is located in the installation directory of 
the SDK. It’s in PDF format, so you’ll need Adobe Acrobat Reader to open it. Adobe 
Acrobat reader is freely available from www.adobe.com.

http://www.adobe.com
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2
Configuring for Browser and Message Content 
Development

You can work more efficiently by creating an integrated development environment 
(IDE) where you can develop content in an application and directly display it on the 
SDK. Some applications automatically detect the SDK as a device. You’ll need to 
configure other applications to recognize the SDK before you can use the SDK from 
within the application’s interface. 
For detailed information about step-by-step installation instructions, see the 
documentation of the supporting application. This chapter provides only a general 
overview of what you need to do about configuring these content authoring applications 
for use with the Series 40 SDK 3rd Edition:

• Adobe GoLive with Nokia Developer’s Suite for MMS (NDS for MMS) for message 
development
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• Adobe GoLive with the WML module for WML and XHTML browsing.

Configuring NMIT to use the SDK 
NMIT 4.1 automatically finds the SDK and configures itself to use it.

Configuring NDS for MMS to use the SDK
NDS for MMS 1.1 automatically finds the SDK and configures itself to use it.

Configuring Adobe GoLive to display MMS messages on the SDK
If you are planning to send MMS messages to the SDK while using Adobe GoLive, you’ll 
need to install Nokia Developer’s Suite for MMS (NDS for MMS) after you install 
Adobe GoLive. NDS for MMS is automatically configured to run with the SDK within 
Adobe GoLive. You do not need to configure it manually. NDS for MMS adds a Nokia 
Tools menu to the Adobe GoLive menu bar. Under this menu, you’ll see the option, 
Create/Send MMS Messages, which starts NDS for MMS.

Configuring Adobe GoLive to display WML and XHTML content 
on the SDK

By default, the WML module for content authoring is not accessible unless you add the 
module in Adobe GoLive preferences before you configure Adobe GoLive to recognize 
the SDK as a browser. 
To configure Adobe GoLive so you can create a new WML file using a standard WML 
template:

1 Select Edit>Preferences.

2 On the right panel, select Modules.

3 On the left panel, navigate to the bottom of the list to the Extend Scripts folder and 
check WML.

4 Click OK. 

Now you can create a new WML file by selecting File>New Special>WML Deck.

To add Series 40 SDK 3rd Edition as a recognized browser to Adobe GoLive:

1 Select Edit>Preferences.

2 On the right panel, select Browser.

3 Click Add. The Choose Browser dialog box appears. 
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4 In the Choose Browser dialog box, navigate to the location of the SDK executable file 
(C:\Nokia\Devices\S40_SDK_3rd_Edition\bin\sdk.exe) and click OK. 

Now you can display a WML or XHTML file within GoLive’s content editor on the 
SDK by selecting File>Preview In>sdk.exe.

What’s next?
You can begin to use the Series 40 SDK 3rd Edition. See the Series 40 Software Developer 
Kit 3rd Edition User’s Guide for information about using the SDK. For late-breaking 
information, see the release notes. Both documents are located in the installation 
directory of the SDK. You can also download the documents from 
www.forum.nokia.com. The manual is in PDF format, so you’ll need Adobe Acrobat 
Reader to open it. Adobe Acrobat reader is freely available from www.adobe.com.

http://www.forum.nokia.com
http://www.adobe.com
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3
Configuring the SDK for MIDP Development

You can work more efficiently by creating an integrated development environment 
(IDE) where you can develop a MIDlet in an application and directly test it on the SDK. 
Some applications automatically detect the SDK as a device. You’ll need to configure 
other applications to recognize the SDK before you can start the SDK from within the 
application’s interface. 
For detailed information about step-by-step installation instructions, see the 
documentation of the IDE. This chapter provides only a general overview of what you 
need to do to configure these MIDP development applications to use the Series 40 SDK 
3rd Edition:

• Borland JBuilder

• Nokia Developer’s Suite for the Java™ Platform, Micro Edition (NDS for Java ME)

• Sun NetBeans

• Eclipse
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Configuring JBuilder to use the Series 40 SDK 3rd Edition
You can use the Series 40 SDK 3rd Edition as a Java Developer’s Kit (JDK) and as the 
default device in a JBuilder project. You might notice differences in the look of the 
JBuilder interface, depending on the version of JBuilder you are using, but the procedure 
works identically. 

Configuring JBuilder to recognize the SDK as a JDK
To configure JBuilder to recognize the SDK as an installed JDK:

1 In the JBuilder main window, choose Tools>Configure JDKs. The Configure JDKs 
window appears.

2 Click New in the Configure JDKs window to start the New JDK Wizard.

3 In the New JDK Wizard, do this:

• In Existing JDK home path, enter the SDK’s root installation directory.

• In Name for this JDK, enter a name by which you want JBuilder to refer to the 
SDK, such as Series 40 SDK 3rd Edition.

• Click OK to close the New JDK Wizard.

4 The Configure JDKs window now lists the SDK on the left panel:

5 Click OK to close the window.

Configuring a JBuilder project to use the Series 40 SDK 3rd Edition
To configure a JBuilder project to use the SDK:
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1 From the left panel of the JBuilder main window, choose the project you created and 
select Projects>Project Properties to display its properties. The Project Properties 
window appears:

.

2 Click Paths in the left panel. Then click the button to the right of the JDK field, and 
select the Nokia SDK as the SDK to be used for this project. 

3 Click Run in the left panel to create a runtime configuration for the project.

4 Click New. The New Runtime Configuration window appears:
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5 For Type, select MIDlet to configure the runtime parameters you want to use when a 
MIDlet runs on the Series 40 SDK 3rd Edition. The window changes to look like this:

.

6 With the window set to MIDlets, do one of the following:

• Click the button adjacent to Main class to display the Choose Main class to run 
window. In this window, navigate to the location of the files of your main class. 
Click OK.

• Click the button adjacent to JAD file to display the Choose JAD file to run 
window. In this window, navigate to the location of the JAD file for your MIDlet. 
Click OK.

7 Click OK to close the New Runtime Configuration window.

8 Click OK to close the Project Properties window.

9 In the JBuilder main window, select Run>Project to load and execute the MIDlet on 
the SDK.

Configuring JBuilder to use the SDK with J2ME Wireless Toolkit
J2ME Wireless Toolkit (J2MEWTK) is automatically installed when you install 
JBuilder.
To configure the SDK with J2MEWTK so the SDK will appear in J2MEWTK's list of 
supplied emulators:

1 Install JBuilder before you install the SDK.

You can enter command 
line options here. See 
Running the SDK from a 
Command Line in the 
Series 40 Software 
Developer Kit 3rd Edition 
User’s Guide.
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2 Install the SDK. During installation, do not click the button labeled integrated with 
Sun J2ME WTK.

3 After the SDK is installed, copy the entire SDK installation directory structure into:
<JBuilder-install-directory>\J2mewtk\wtklib\devices

The SDK installation directory is the S40_SDK_3rd_Edition directory, which is 
located by default in C:\Nokia\Devices.

To make the SDK the active device emulator within J2ME Wireless Toolkit:

1 In the JBuilder main window, select Tools>Configure JDKs. 

2 Select J2ME Wireless Toolkit in the left panel and click the Micro tab in the right 
panel. The SDK appears as an option under Target Device:

3 Select the SDK from Target Device to make it active.

4 Click OK.

Configuring the SDK with NDS for Java ME through JBuilder
Make sure you chose the Borland JBuilder Integration option when you installed NDS 
for Java ME.
To configure the SDK with NDS for Java ME through JBuilder:

1 In the JBuilder main window, select 
Tools>Nokia Developer’s Suite for J2ME(TM)>Configure Emulators.

2 Click Add.

3 In the Open dialog box that appears, navigate to the SDK’s configuration file and 
select the home directory of the SDK.

4 Click Open.

5 In the Configure Emulators window, check that the SDK name appears in the 
Emulator list.

6 Click Close.

Configuring the SDK with NDS for Java ME
To configure the SDK with NDS for Java ME:

1 In the NDS for Java ME main window, select Emulators > Configure Emulators.

2 Click Add.

3 In the Open dialog box that appears:

• Under File Name, enter the home directory of the SDK

• Under Files of Type, select UEI emulator root directory

4 Click Open.
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5 In the Configure Emulators window, check that the SDK name appears in the 
Emulator list.

6 Click Close.

Configuring the Series 40 SDK 3rd Edition with Sun NetBeans
To configure the Series 40 SDK 3rd Edition for use with Sun NetBeans:

1 In Sun NetBeans, click the Runtime tab at the bottom of the Explorer panel. 

2 Right click on the Device Emulator Registry node and choose Add Emulator. 

3 The Add Emulator window appears. Click Browse and navigate to the SDK’s home 
directory (typically, C:\Nokia\Devices\S40_SDK_3rd_Edition) and click 
Open.

4 In the Detected Emulator Type field, make sure Standard UEI Emulator is selected, 
and click Next. The window is updated with read-only SDK configuration 
information. 

5 Click Next. The window is updated with Emulator Details. 

6 Select the Series 40 SDK 3rd Edition as an emulator device by checking its box.

7 Click Finish. The Add Emulator window closes. You have added the SDK to the IDE. 

To select the Series 40 SDK 3rd Edition as the default SDK:

1 Click on Device Emulator Registry to open it. 

2 Select the Series 40 SDK 3rd Edition from the list of installed emulators. 

3 Right-click on the Series 40 SDK 3rd Edition and select Set As Default. 

What’s next?
You can begin to use the Series 40 SDK 3rd Edition. See the Series 40 SDK 3rd Edition 
User’s Guide for information about using the SDK. For late-breaking information, see 
the release notes. Both documents are located in the installation directory of the SDK. 
You can also download the documents from www.forum.nokia.com.The manual is in 
PDF format, so you’ll need Adobe Acrobat Reader to open it. Adobe Acrobat reader is 
freely available from www.adobe.com.

http://www.forum.nokia.com
http://www.adobe.com
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